[SOLVED] Can't install 2020 Mega Patch - XwaInstallerLib Config Error

Any issues with the XWAU or X-Wing Alliance? Please let us know here!
Post Reply

[SOLVED] Can't install 2020 Mega Patch - XwaInstallerLib Config Error

Erecshyrinol
Recruit
Posts: 2
Joined: Wed Jan 13, 2021 2:07 pm

Post by Erecshyrinol » Wed Jan 13, 2021 6:56 pm

Hi,

I recently bought XWA off GOG's recent sale and thought I'd fire it up properly modded up-to-date. However, for some reason the XWAU installer simply refuses to start, crashing on a XwaInstallerLib Config Error (screenshot attached).

I have XWA installed in GOG's suggested default folder on drive E (E:\Program Files (x86)\GOG.com), it's a fresh install without anything added, haven't even started it up yet. The XWAU2020 installer should be OK too, its MD5 hash matching that given on the downloads page.

On running the installer for the first time after starting my computer, AVAST springs up and wants to check it (even though I manually scanned the file as well right after downloading - reported all OK), that check runs and says everything's okay, the next thing is the crash/error message window, the installer never manages to get going properly. On the several times I've tried, I think I've seen the installer's small splash screen poppin up once or twice before the crash.

Any ideas what could be wrong here and what could I try next?

Thanks

EDIT: Yep, moving the installer to another location than a root director of a drive did the trick. Thanks again!


Game version: GOG 2.02 (18061)
Operating system: Windows 7 (service pack 1)
No additional installers in place - trying to install mod for the first time.

Here's the error massage again in text form:
XwaInstallerLib Config Error

System.ArgumentNullException: Value cannot be null.
Parameter name: path1
at System.IO.Path.Combine(String path1, String path2)
at XwaInstallerLib.XwaSettings.IsXWADirectory(String directory)
at
XwaInstallerLib.XwaSettings.ReadDestinationFolderFromCurrent
Directory()
at XwaInstallerLib.XwaSettings.ReadDestinationFolder()
at
XwaInstallerLib.WizardWindow.SetDefaultDestinationFolder()
at XwaInstallerLib.Wizardwindow..ctor()
at XwaInstallerLib.Main.Config()
You do not have the required permissions to view the files attached to this post.
Last edited by Erecshyrinol on Thu Jan 14, 2021 1:41 am, edited 1 time in total.

User avatar
JeremyaFr
XWAU Member
Posts: 2898
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Wed Jan 13, 2021 7:11 pm

Hello,
This exception is thrown when the installer file is at the root of a drive.
Create a folder and move the installer into it. This should fix the exception.

Erecshyrinol
Recruit
Posts: 2
Joined: Wed Jan 13, 2021 2:07 pm

Post by Erecshyrinol » Wed Jan 13, 2021 8:07 pm

I'll give that a try. Thanks!

Post Reply