Bug Reports

A forum for the TIE Fighter Total Conversion Project (TFTC). Here you can find out news, updates, FAQs or just ask questions about the project.

Moderators: Bman, AngeI

Re: Bug Reports

brakogar
Recruit
Posts: 9
Joined: Thu Jul 08, 2021 4:39 am

Post by brakogar » Tue Jul 20, 2021 2:13 pm

Hi Team,

TFC is fantastic and despite some of my previous issues I managed to get it going well. VR however has an issue that I have not seen addressed by others - When a 'original Tie' cutscene plays, it does not show in the VR headset and instead I get a SteamVR 'XWA now loading' message box until the cutscene finishes - I can still hear the sound in VR.

The same also goes for the intro but strangely enough the stock 'Totally Games' logo bit plays just fine in VR but goes dark again when the Tie intro plays. If I take the headset off, I can see the Tie cutscenes / intro on the monitor.

Is this intended or is something not right here? Here my parameters and what I have done to troubleshoot:

- Using SteamVR
- Changed VR resolution to the lowest and tried higher resolutions - No change to issue.
- Turned off 'go to VR grid when app hangs' SteamVR developer option.
- Changed app specific resolution, tried several from low to high - No change

Any help would be great. Thank you.

User avatar
AngeI
Ensign
Posts: 351
Joined: Sun Jan 24, 2016 5:27 pm

Post by AngeI » Wed Jul 21, 2021 6:35 pm

Its known that the cutscenes do not work with VR presently. @blue_max may be able to explain better why.

User avatar
blue_max
XWAU Member
Posts: 1885
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Wed Jul 21, 2021 7:00 pm

This is a known issue. There's a file called TgSmush.dll in your XWA install directory. Make a backup copy of this file and rename TgSmushOrig.dll to TgSmush.dll (effectively replacing it). That should show the films again in VR, but they will be lower quality (and there may be other issues too).

The reason this is happening is because TgSmush.dll displays films directly to the desktop, bypassing the DirectX system, that's why you don't see anything on your headset. This can probably be fixed, but we need time to figure this out.

brakogar
Recruit
Posts: 9
Joined: Thu Jul 08, 2021 4:39 am

Post by brakogar » Wed Jul 21, 2021 11:05 pm

Thank you for replying, good to know as I couldn't find info on it. I will try renaming the file. I appreciate your help.

brakogar
Recruit
Posts: 9
Joined: Thu Jul 08, 2021 4:39 am

Post by brakogar » Thu Jul 22, 2021 10:05 am

blue_max wrote:
Wed Jul 21, 2021 7:00 pm
This is a known issue. There's a file called TgSmush.dll in your XWA install directory. Make a backup copy of this file and rename TgSmushOrig.dll to TgSmush.dll (effectively replacing it). That should show the films again in VR, but they will be lower quality (and there may be other issues too).

The reason this is happening is because TgSmush.dll displays films directly to the desktop, bypassing the DirectX system, that's why you don't see anything on your headset. This can probably be fixed, but we need time to figure this out.
Hi,

I tried renaming the TgSmushOrig.dll 'replacing' the original TgSmush.dll file as instructed but the result is that the cutscenes no longer show at all now, it just skips to the game 'main menu'. Only the Totally Game logo still shows.

I also tried to change the TgSmush.cfg file to PreserveAspectRatio = 0 (instead of 1) but that had no effect. It's like if I had chosen 'skip intro' on the start window.

Firehsk
Recruit
Posts: 1
Joined: Thu Jul 22, 2021 2:42 pm

Post by Firehsk » Thu Jul 22, 2021 2:51 pm

Don't know if it's intended or a bug:

TFTC Version 1.1

Battle 3 Mission 3 - classic

When the enemy cruiser appears half of the spawned imperial fighters fly back to the hangar. So this misison is just unbeatable

Enemy cruiser spawns about 5k away from my own, B-Wings and X-Wings launch and immediately fire their torpedos. My own remaining ships get shot to pieces by the cruisers turbolasers. There is no chance getting the enemy fighters an preventing the enemy combined with the y-wings from destroying my own mission critical ship and in the result a failed mission.

Replayed the mission in the original Tie Fighter and it wasn't that hard there. Really frustrating

User avatar
blue_max
XWAU Member
Posts: 1885
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Thu Jul 22, 2021 5:33 pm

brakogar wrote:
Thu Jul 22, 2021 10:05 am
I tried renaming the TgSmushOrig.dll 'replacing' the original TgSmush.dll file as instructed but the result is that the cutscenes no longer show at all now, it just skips to the game 'main menu'. Only the Totally Game logo still shows.
So, just to be sure, you do have one file called TgSmush.dll in your XWA directory right?

brakogar
Recruit
Posts: 9
Joined: Thu Jul 08, 2021 4:39 am

Post by brakogar » Fri Jul 23, 2021 12:00 am

blue_max wrote:
Thu Jul 22, 2021 5:33 pm
brakogar wrote:
Thu Jul 22, 2021 10:05 am
I tried renaming the TgSmushOrig.dll 'replacing' the original TgSmush.dll file as instructed but the result is that the cutscenes no longer show at all now, it just skips to the game 'main menu'. Only the Totally Game logo still shows.
So, just to be sure, you do have one file called TgSmush.dll in your XWA directory right?
That's right, it is the former TgSmushOrig.dll file renamed to TgSmush.dll. The original file is backed up away. If I restore the original file, I get the 'black in VR' intro/cutscenes back but if I use TgSmushOrig.dll (renamed to TgSmush.dll) it just skips Tie cutscenes altogether.

User avatar
blue_max
XWAU Member
Posts: 1885
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Fri Jul 23, 2021 12:59 am

brakogar wrote:
Fri Jul 23, 2021 12:00 am
That's right, it is the former TgSmushOrig.dll file renamed to TgSmush.dll. The original file is backed up away. If I restore the original file, I get the 'black in VR' intro/cutscenes back but if I use TgSmushOrig.dll (renamed to TgSmush.dll) it just skips Tie cutscenes altogether.
Alright, just wanted to make sure. Yes, we're aware of this problem. Unfortunately, the author of that library is busy at the moment and we're going to need some time to address this properly.

brakogar
Recruit
Posts: 9
Joined: Thu Jul 08, 2021 4:39 am

Post by brakogar » Fri Jul 23, 2021 2:58 am

blue_max wrote:
Fri Jul 23, 2021 12:59 am
brakogar wrote:
Fri Jul 23, 2021 12:00 am
That's right, it is the former TgSmushOrig.dll file renamed to TgSmush.dll. The original file is backed up away. If I restore the original file, I get the 'black in VR' intro/cutscenes back but if I use TgSmushOrig.dll (renamed to TgSmush.dll) it just skips Tie cutscenes altogether.
Alright, just wanted to make sure. Yes, we're aware of this problem. Unfortunately, the author of that library is busy at the moment and we're going to need some time to address this properly.
Cool and no worries, thank you for passing it on. I am sure we all appreciate what you are doing! :)

a_lost_shadow
Recruit
Posts: 1
Joined: Tue Jul 20, 2021 7:38 pm

Post by a_lost_shadow » Sat Jul 24, 2021 5:10 am

Battle 3 Mission 1 - Reimagined

Pressing O (Target next objective craft) only targets the un-inspected containers with the mission contents. I was expecting it to only target the next un-inspected container regardless of whether it was empty or contained the mission contents.

Info:
- Win 7 machine
- Steam based install
- Install order
---- 2020 Mega Patch
---- 2020 Patch 4
---- TFTC 1.0
---- TFTC 1.1

User avatar
the_stag
Cadet 2nd Class
Posts: 61
Joined: Sun Jun 14, 2020 3:47 pm

Post by the_stag » Sat Jul 24, 2021 4:36 pm

Not so much a bug as a quality of life improvement:
Battle 6, Mission #3: Punitive Raid:
When the ISDII Glory arrives at the end of the mission, it has the Chimera skin on it.

smm2303
Cadet 3rd Class
Posts: 35
Joined: Sat Sep 23, 2017 6:46 am

Post by smm2303 » Sat Jul 24, 2021 5:07 pm

Just Playing Battle 11 Mission 5 CLASSIC Where (>Hunt for Zaarin, Mission #5: The Real Thing). After destroying all ATR and Gunboats and Inspecting Traitor Capital Ships, The Grey Wolf arrives. And Glory and Medium Transports (with Missile boats cargo) jumps to Hyperspace and mission fails. Tried 6-7 Times. What's the issue or something wrong I am doing???

User avatar
AngeI
Ensign
Posts: 351
Joined: Sun Jan 24, 2016 5:27 pm

Post by AngeI » Sat Jul 24, 2021 7:39 pm

@Blazingfirestorm

Blazingfirestorm
Cadet 1st Class
Posts: 177
Joined: Sat Dec 09, 2017 9:39 pm

Post by Blazingfirestorm » Sun Jul 25, 2021 9:38 am

I’ll take a look @AngeI

Blazingfirestorm
Cadet 1st Class
Posts: 177
Joined: Sat Dec 09, 2017 9:39 pm

Post by Blazingfirestorm » Sun Jul 25, 2021 10:20 am

@smm2303 I 've fix the issue if you go to the TFTC public discord look for the #quick-fixes and the fix will be posted there

r0bman32
Recruit
Posts: 1
Joined: Mon Jul 12, 2021 3:02 am

Post by r0bman32 » Tue Jul 27, 2021 3:58 am

Battle 4 Mission 4 (Diplomatic Meeting) / Reimagined

Before any enemies jump in, one of the planetary fighters decides to take out Alpha 2 (TIE/In wingman). Then, random Habeen allies seem to target the player during the dogfight with the Skiprays and Y-Wings. Only way to stop it is to shoot them down... anyone else experiencing this?


Never mind... found a fix on Discord.

Another thing I've noticed... does anyone else's Assault Gunboat cockpit rotate randomly? Sort of seems like the head-turn of a pilot in pre-XWAU days. Pretty sure this isn't a TFTC bug and an overall XWAU but in the .opt, but thought I'd mention it anyway.

Guyofthe80s
Recruit
Posts: 7
Joined: Tue Sep 22, 2020 9:26 pm

Post by Guyofthe80s » Wed Jul 28, 2021 9:14 pm

First off, this has been amazing.

Running 1.1

The bug I'm having is the first mission of the second campaign. After inspecting the freighters and the Imperial transports disable and dock with them, the first freighter is destroyed almost immediately after being captured. I've checked and there are no enemy ships near the transports. I've play

Blazingfirestorm
Cadet 1st Class
Posts: 177
Joined: Sat Dec 09, 2017 9:39 pm

Post by Blazingfirestorm » Wed Jul 28, 2021 9:33 pm

@Guyofthe80s is that reimagined or classic

Guyofthe80s
Recruit
Posts: 7
Joined: Tue Sep 22, 2020 9:26 pm

Post by Guyofthe80s » Wed Jul 28, 2021 10:16 pm

Just noticed like... half of my comment got wiped before posting. odd.

Anyway, it's Reimagined.

Blazingfirestorm
Cadet 1st Class
Posts: 177
Joined: Sat Dec 09, 2017 9:39 pm

Post by Blazingfirestorm » Wed Jul 28, 2021 10:28 pm

Guyofthe80s wrote:
Wed Jul 28, 2021 10:16 pm
Just noticed like... half of my comment got wiped before posting. odd.

Anyway, it's Reimagined.
I've posted a fix in the TFTC public discord #Quick-fixes channel

sark716
Cadet 4th Class
Posts: 19
Joined: Wed Sep 09, 2020 2:07 pm

Post by sark716 » Thu Jul 29, 2021 7:08 pm

Hi everyone. I'm having problems with TFTC Battle 3. Mission 5. After around 11 mins the game completely crashes, and returns to Windows. Any ideas ?

Kramah313
Recruit
Posts: 5
Joined: Thu Nov 05, 2020 3:41 am

Post by Kramah313 » Thu Jul 29, 2021 9:24 pm

After playing some more I have found that the ELS energy presets (F11/F12) both reset to 0 throttle and 0% energy for lasers and shields if you go to any of the sub menus from the main menu (such as the sound settings or general settings). If you reset them in game using shift+F11 or shift+F12, they’ll stay as you set them until you go to a sub menu from the main menu again. I’m not sure what is causing that but my suspicion is that it might have to do with flying craft that don’t have shields such as the TIE fighter.

Guyofthe80s
Recruit
Posts: 7
Joined: Tue Sep 22, 2020 9:26 pm

Post by Guyofthe80s » Fri Jul 30, 2021 5:16 pm

Yeah, another from me!
Reimagined Battle 3 Mission 3 sees some Z-95 Headhunters just fly off away from the battle towards the nearest star (I don't blame them). This causes the AI TIE Fighters and Interceptors to chase them after the other Rebel and pirate fighters/bombers have been eliminated. This causes a LONG delay in the fight as the AI fighters are now 40 KM away and once those fleeing Z-95s are dealt with, it leaves the player completely alone with a Rebel frigate and a few wings of X-Wings, B-Wings, and Y-Wings to deal with while the new Z-95s head off in the same manner as the previous wave.

Plutonia
Recruit
Posts: 3
Joined: Wed Jul 21, 2021 10:39 pm

Post by Plutonia » Fri Jul 30, 2021 7:07 pm

I got tired of being instakilled by stray fire in the hyperdrive tech mission and decided to cheat so that I could get the mission over with, and not waste my time flying for 10 minutes and getting a game over with no warning, and repeat. But it didn't actually help because the Tour Invulnerable option is broken. The player's fighter still takes damage and systems will go down, they just can't be fully destroyed. This wouldn't really be an issue, since the whole point of the cheat is to be able to play the game without dying instantly due to flying a TIE, but there's another bug that makes this game-breaking. The repair timers for the malfunctioning systems are stuck in their starting values. If something takes 15 seconds to repair, the clock will say 15 forever and the system will never come back online. So, if you're ever unfortunate enough to take even one hit, and that hit happens to knock out your flight control, your mission is over because you can't fly anymore.

Post Reply