Bug Reports

A forum for the TIE Fighter Total Conversion Project (TFTC). Here you can find out news, updates, FAQs or just ask questions about the project.

Moderators: AngeI, Bman

Bug Reports

User avatar
AngeI
Ensign
Posts: 326
Joined: Sun Jan 24, 2016 5:27 pm

Post by AngeI » Wed Jun 30, 2021 10:50 am

If you experience any bugs or issues with TFTC, please post here. Be as detailed as possible, include screenshots, video links and how we can replicate this bug. The more details we have, the easier it is to fix for future patches!

Kramah313
Recruit
Posts: 5
Joined: Thu Nov 05, 2020 3:41 am

Post by Kramah313 » Sat Jul 03, 2021 2:52 pm

In mission 4 of the training campaign (the one where you’re flying an assault gunboat vs mines and a calamari cruiser), the ELS energy presets don’t seem to work correctly. No matter what I save them as using Shift+F11 or Shift+12, or what I set them at in the menu, they only seem to work for a little while (probably until I die) before both presets revert to everything at 0%, including throttle.

For the most part the presets hold correctly in the TIE fighter/interceptor/bomber, even carrying over from the XWA upgrade.

Minor issue through, just about everything else seems great! Was a lot of fun.

Random Starfighter
Cadet 4th Class
Posts: 24
Joined: Tue Oct 13, 2020 12:14 am

Post by Random Starfighter » Sat Jul 03, 2021 5:36 pm

There's two unresolved bugs I haven't been able to find solutions for.

The first one, I don't hear any voice acting in the briefings. The briefings and in-flight messages are completely silent. Game sounds are enabled. Other users have confirmed that the voices work fine for them. Fully reinstalling from vanilla XWA doesn't help.
EDIT2: Forgot to mention that the concourse doesn't load correctly either. Maybe it's related.
TFTC concourse.jpg
Another problem is that sometimes enemy projectiles do way more damage than they should. For example in the gunboat training mission with the mines, a single laser from a single mine can sometimes inflict as much as 20-25% damage to my shields when normally they should only do like 5%. When the laser strikes, it sounds like there are multiple impacts.

Following that, enemy starfighters have a similar problem. During the cruiser phase, I went from 200% shields to dead in just a few volleys from the X-wings. Something is definitely wrong with the projectiles. I've been able to replicate the issue in skirmish mode, but it doesn't always happen. Will take some more investigation.

EDIT: Short video here: https://drive.google.com/file/d/16FVpha ... sp=sharing
Projectile damage is normal, but it does seem to cause multiple impacts, which stacks up extra damage.
Later I'm forcibly despawning the lasers to get close to the mine, because I had a theory that there were lingering projectiles, or stacked projectiles. But it seems the projectile count is fine. I wonder, if the resulting impact explosion is also inflicting damage?

I encountered other problems with startup crashes and joystick issues, but I was able to resolve them. Writing here for documentation in case anybody else has similar issues.

(Resolved) Joystick button anomalies
Exit XWA and open the XWA Joystick Config utility.
Click "Init buttons (index)" this will reset all the bindings, but it will fix the list to show proper buttons for each device.
Then rebind your controls, and make sure one device's buttons aren't conflicting with another. Especially if you have a vJoy virtual device like I do.

In my specific case, vJoy buttons and original device buttons were mapped to different functions, any both were activating at the same time from the same button press. The vJoy button I had assigned to targeting was also performing match speed (which on the case of mines was 0% throttle). I solved this by clearing the bindings for the original device, so it only used my vJoy bindings.

If anyone has a similar problem, it may be worth checking for conflicts.


(Resolved) XWAU Upgrade 4 crashes on startup
See this thread, but basically the solution is to enable Data Execution Prevention (DEP) for XwingAlliance.exe. If the Control Panel settings aren't working, Windows Security has a different set of settings which need to be applied.

Control Panel > System > Advanced System Settings > Advanced Tab, Performance Settings > Data Execution Prevention Tab.
Make sure DEP enabled for all programs, except those in the list. Then
DEP on for all programs, except those in the list. Click Add, then browse and select XwingAlliance.exe.

Windows Security > App & Browser Control > Exploit Protection Settings.
Under System Settings, make sure Data Execution Prevention is set to Default (On).
Under Program settings, click "Add program to customize", then browse and select XwingAlliance.exe.
Then edit the settings for the new entry, scroll down to Data Execution Prevention, make sure "Override system settings" is checked, and the switch set to Off. Then apply the settings.
You do not have the required permissions to view the files attached to this post.

User avatar
Ace Antilles
Admiral (Moderator)
Posts: 6124
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Sun Jul 04, 2021 2:09 pm

Random Starfighter wrote:
Sat Jul 03, 2021 5:36 pm
There's two unresolved bugs I haven't been able to find solutions for.

The first one, I don't hear any voice acting in the briefings. The briefings and in-flight messages are completely silent. Game sounds are enabled. Other users have confirmed that the voices work fine for them. Fully reinstalling from vanilla XWA doesn't help.
EDIT2: Forgot to mention that the concourse doesn't load correctly either. Maybe it's related.
TFTC concourse.jpg
If your concourse is showing that the TFTC didn't install correctly as it overwrites files.
Revert to the Lightside in Palpatine and covert back and try again. Otherwise remove the TFTC, redownload and reinstall
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

User avatar
Ace Antilles
Admiral (Moderator)
Posts: 6124
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Sun Jul 04, 2021 2:11 pm

FYI TO ALL
When installing TFTC it's important you have enough free space on your main Windows Drive.
By that you need at least 20gb extra space to allow for the installer to unpack and extract.
if you don't then your TFTC installer will just close on you.

If your Windows temp folder is located on another drive with enough space you should be fine.

If If your Windows drive is below 10gb then you are going to get issues with a lot of stuff going forward
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

Random Starfighter
Cadet 4th Class
Posts: 24
Joined: Tue Oct 13, 2020 12:14 am

Post by Random Starfighter » Sun Jul 04, 2021 5:22 pm

Ace Antilles wrote:
Sun Jul 04, 2021 2:09 pm
If your concourse is showing that the TFTC didn't install correctly as it overwrites files.
Revert to the Lightside in Palpatine and covert back and try again. Otherwise remove the TFTC, redownload and reinstall
I've reinstalled about 4 times now, it's always the same every time. Originally I was using a disc install as a base. My last two installs were using GOG, but still no luck.

The Palpatine converter issues when error when trying to revert back to Lightside.

Code: Select all

System.IO.IOException: Cannot create a file when that file already exists.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.Directory.InternalMove(String sourceDirName, String destDirName, Boolean checkHost)
   at XwaInstallerLib.IOHelpers.RenameDirectory(String basePath, String sourcePath, String destinationPath)
   at XwaInstallerLib.PackageInstaller.RenameDirectoryFunction(String[] lineParts)
   at XwaInstallerLib.PackageInstaller.InstallScript(List`1 scriptLines, Dictionary`2 patchFiles)
   at XwaInstallerLib.PackageInstaller.InstallPackage(String packagePath)
   at XwaInstallerLib.ConsoleWindow.<>c__DisplayClass88_1.<Window_Loaded>b__1()
   at System.Threading.Tasks.Task.InnerInvoke()
   at System.Threading.Tasks.Task.Execute()
Looks like it's trying to move a directory, but it doesn't mention what it is.

Anyway, using the Palpatine converter to revert and reinstall TFTC does nothing to fix it. Concourse still looks like the screenshot I posted.

In other news, the damage bug is not because of TFTC. It's something in XWAU itself.
EDIT: The damage bug is caused by turning cockpits off. Whether dynamic cockpits or static cockpits, toggling off (via "." key). Damage is normal as long as the cockpit is present. The bug is present in the original XWAU Mega Patch, and persists throughout Update 4 and TFTC.

darth xenu
Recruit
Posts: 6
Joined: Mon Jan 15, 2007 12:01 am
Contact:

Post by darth xenu » Mon Jul 05, 2021 7:36 am

I have a problem with Battle 2 Mission 4. Shuttle Phantele keeps getting destroyed by empire ships. I get the report that the ship is disabled and then almost immediately it's destroyed. I can see a gunboat torepedoing it. Anyone else seeing this.

User avatar
AngeI
Ensign
Posts: 326
Joined: Sun Jan 24, 2016 5:27 pm

Post by AngeI » Mon Jul 05, 2021 12:34 pm

@Random Starfighter are you sure you are installing everything correctly from scratch: XWA --> XWAU --> XWAU Update 4 --> TFTC ? I'd test the game launches ok every step of the way. Also make sure not in a protected folder like Program Files and finally that you have enough free space on your C: Drive (At least 30-40GB or more). Otherwise @DTM might need to help with debugging that error.

@darth xenu this is a known bug currently with B2M4 Reimagined, we have a quick fix for this on our discord, but I'll post it here below as well. Put it into your Missions folder.
You do not have the required permissions to view the files attached to this post.

Bailknight
Recruit
Posts: 5
Joined: Sun May 05, 2019 2:50 pm

Post by Bailknight » Mon Jul 05, 2021 3:50 pm

I don't know this is bug or intended but I failed many times on reimagined B1M2 because when after I inspect mission object shuttle 3 X-wings spawned near shuttle and kill it despite of same side and before I (actually empire) attempt to disable or capture it.

Also In training when I died and respawned landing gear stuck on open position so I can't fire laser before I manually close gears.

Lastly I use 400% hull option but It seems not working because I think I always died by 2shots. I thought TIE fighter hull need 2 laser shots to kill on 100% default.
Last edited by Bailknight on Tue Jul 06, 2021 1:35 am, edited 2 times in total.

darth xenu
Recruit
Posts: 6
Joined: Mon Jan 15, 2007 12:01 am
Contact:

Post by darth xenu » Mon Jul 05, 2021 10:16 pm

@Angel Thanks for the quick response. That worked great.

Random Starfighter
Cadet 4th Class
Posts: 24
Joined: Tue Oct 13, 2020 12:14 am

Post by Random Starfighter » Tue Jul 06, 2021 12:13 am

EDIT: Okay, so classic case of PEBKAC. As was helpfully pointed out to me, I was running the wrong Palpatine Converter all along.

Rather than using Alliance.exe, because I never use Alliance.exe for anything, and I figure I'm accustomed to installing things manually... I just said "okay Palpatine Converter, TFTC, got it" and went into the TotalConverter folder and ran PalpatineTotalConverterTFTC.exe. The wrong one.

So I ran the wrong converter, and launched TFTC for the first time. Okay, the concourse isn't loading properly. Start the first training mission. No voice acting? I thought there was voice acting? Whatever, I'm not really invested into training missions anyway. After a couple missions, I decided I'm not liking the new cockpits. Text is hard to read, and the flashy lights and effects are distracting. So I exit out and run BabuFriksConfigurator.exe. Nothing changed, I realized I needed to run BabuFriksConfiguratorTFTC.exe.

Now this is where everything went wrong, because it mentally solidified the idea that I need to run the TFTC-named installers. Figuring that PalpatineTotalConverter2.exe (the correct one all along) was some default XWAU thing.

After finishing the training missions, I decided I really wanted the voice acting before continuing. I deleted XWA and reinstalled. Forgot to backup my pilot file, so I had to play through the training missions again. Not using the cockpit anymore, I'm really getting messed up by the damage bug. So the remainder of my time was investigating the bug and repeatedly reinstalling in a vain attempt to fix TFTC while I was at it, running PalpatineTotalConverterTFTC.exe every time. At one point I had even tried PalpatineTotalConverterTFTC-R.exe, no luck. But in these TFTC converters I saw the option to restore the Light Side, so I just assumed they were the correct programs.

At one point during reinstalling I had watched the instruction video, but glossed over the part about launching the Palpatine Converter from Alliance.exe

So that's my story. Should have followed instructions more closely, and not been so quick to dismiss PalpatineTotalConverter2.exe which is THE ONE TRUE INSTALLER. Bug resolved, and I feel like an idiot. Hopefully someone finds my story amusing.

Porkins_BB
Cadet 3rd Class
Posts: 49
Joined: Wed Nov 25, 2020 1:42 pm

Post by Porkins_BB » Tue Jul 06, 2021 5:45 pm

Just started playing it and have come across a couple of bugs. (Note: not sure if this is Mega Patch 4 related or TFTC)

1. Tie Bomber Training Mission: Everything was working great at the start. But, after I fired my first 6 torpedoes and went back for a reload, I could no longer fire my lasers. It kept saying "Unable to fire lasers with S-foils closed or landing gear down". Even though the TB doesn't have such devices, I tried hitting the S-Foils key but it said the craft was not equipped with S-Foils. I was not able to fire the lasers for the rest of the training mission.

2. I'm getting some sound issues and I'm not sure if its Mega Patch 4 or TFTC related. When I'm in the briefing room, there appears to be a loud click or static sound before the briefer begins to speak. It almost sounds like someone is turning on the microphone. Additionally, not sure if its related, but when there are explosions from craft being destroyed there are static sounds following the explosion. These are residual for 5-10 seconds after the craft are destroyed. The more explosions, the more static. I haven't tried tweaking the default sounds yet and I'm not sure if it might be Mega patch 4 as I have not played XWAU since Mega Patch 3.

User avatar
Ace Antilles
Admiral (Moderator)
Posts: 6124
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Tue Jul 06, 2021 7:41 pm

Porkins_BB wrote:
Tue Jul 06, 2021 5:45 pm
Just started playing it and have come across a couple of bugs. (Note: not sure if this is Mega Patch 4 related or TFTC)

1. Tie Bomber Training Mission: Everything was working great at the start. But, after I fired my first 6 torpedoes and went back for a reload, I could no longer fire my lasers. It kept saying "Unable to fire lasers with S-foils closed or landing gear down". Even though the TB doesn't have such devices, I tried hitting the S-Foils key but it said the craft was not equipped with S-Foils. I was not able to fire the lasers for the rest of the training mission.

2. I'm getting some sound issues and I'm not sure if its Mega Patch 4 or TFTC related. When I'm in the briefing room, there appears to be a loud click or static sound before the briefer begins to speak. It almost sounds like someone is turning on the microphone. Additionally, not sure if its related, but when there are explosions from craft being destroyed there are static sounds following the explosion. These are residual for 5-10 seconds after the craft are destroyed. The more explosions, the more static. I haven't tried tweaking the default sounds yet and I'm not sure if it might be Mega patch 4 as I have not played XWAU since Mega Patch 3.
1 - It's landing gear. Ctrl + L. it's to do with the Tie Shuttle profile. It's being fixed.

2. The explosion static is a custom sound from TFTC. ExplosionSparks1.wav I believe. It's way too long.
You can restore the original from the backup folder.
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

smm2303
Cadet 3rd Class
Posts: 35
Joined: Sat Sep 23, 2017 6:46 am

Post by smm2303 » Wed Jul 07, 2021 7:03 am

My Training Tie Laser is RED why?

GreeneSally
Recruit
Posts: 1
Joined: Wed Jul 07, 2021 11:51 am

Post by GreeneSally » Wed Jul 07, 2021 11:55 am

Hi, I had so many problems when I installed the game, but as soon as I put a brand new SSD and a new graphics card everything just started flying, literally. Want to play guys, do not skimp on a good hardware!) :^^: :^^:

smm2303
Cadet 3rd Class
Posts: 35
Joined: Sat Sep 23, 2017 6:46 am

Post by smm2303 » Wed Jul 07, 2021 12:39 pm

Why tie fighter fires RED Lasers???? Training Mission

User avatar
AngeI
Ensign
Posts: 326
Joined: Sun Jan 24, 2016 5:27 pm

Post by AngeI » Wed Jul 07, 2021 1:08 pm

smm2303 wrote:
Wed Jul 07, 2021 12:39 pm
Why tie fighter fires RED Lasers???? Training Mission
This for some reason is only affected training missions so far but is related to brightness settings. Turning this down makes it go away.

smm2303
Cadet 3rd Class
Posts: 35
Joined: Sat Sep 23, 2017 6:46 am

Post by smm2303 » Wed Jul 07, 2021 4:40 pm

Yes reducing Brightness solves the issue. Thank u very much Sir.
But it should be addressed in update I say.

brakogar
Recruit
Posts: 9
Joined: Thu Jul 08, 2021 4:39 am

Post by brakogar » Thu Jul 08, 2021 4:46 am

Issue: No Speech - All other sound effects work fine. No other issues aside from voice speech not present neither in briefings or in flight.

Hi Team,

Thank you or such a great conversion! I am looking forward to fully experiencing it. I was able to successfully install it and ran the Palpatine total conversion from the menu as instructed in the install video but I have run into the following issue (assuming it is one) in both reimagined and classic versions:

During the briefing and in-flight there is no voice speech at all. Music and sound effects appear to be fine. I have tried re-installing from scratch but issue repeats itself. Please advise. Thank you again.

Gringlas
XWAU Member
Posts: 1283
Joined: Mon Oct 30, 2000 12:01 am
Contact:

Post by Gringlas » Thu Jul 08, 2021 5:57 am

Just played for an hour through the training mission and the first mission of the tour of duty. Very nice work so far.
I've got two issues, which maybe are not bugs realy, but didn't wanted to start a new topic for those.

1) Is there no Tech Room available?
2) Don't know if its XWAU or TFTC, but the missile lock sound is annoying as hell. In my mind it sounded very different in Tie Fighter way back.
3) In training mission 4 (Gunboat) I got destroyed. I like that the mission doesn't fail instantly and you get redeployed in a new craft.(Is this a feature in all mission, or only in training?) But it had s-foils closed and landing gears down. Shouldn't it be battle ready?
I just read through this topic and thanks @Ace Antilles I now know the key mapping for landing gears, but which is the key for s-foils (wasn't even able to find it in the original handbook - maybe I'm blind though ^^).
I'm back ^^

User avatar
Forceflow
Fleet Admiral (Administrator)
Posts: 6638
Joined: Wed Oct 20, 1999 11:01 pm
Contact:

Post by Forceflow » Thu Jul 08, 2021 7:57 am

Gringlas wrote:
Thu Jul 08, 2021 5:57 am
Just played for an hour through the training mission and the first mission of the tour of duty. Very nice work so far.
I've got two issues, which maybe are not bugs realy, but didn't wanted to start a new topic for those.

1) Is there no Tech Room available?
There is, it's on the top floor, the glowing hallway should give it away ;)
2) Don't know if its XWAU or TFTC, but the missile lock sound is annoying as hell. In my mind it sounded very different in Tie Fighter way back.
Yeah, this one is tough, don't know if that's the defaul sound for it. @Ace Antilles is that a new sound, or the default sound? Do you have an alternative for it?
3) In training mission 4 (Gunboat) I got destroyed. I like that the mission doesn't fail instantly and you get redeployed in a new craft.(Is this a feature in all mission, or only in training?) But it had s-foils closed and landing gears down. Shouldn't it be battle ready?
I just read through this topic and thanks @Ace Antilles I now know the key mapping for landing gears, but which is the key for s-foils (wasn't even able to find it in the original handbook - maybe I'm blind though ^^).
The respawning is only for the training missions, later on you die you loose ;) The landing gear and sFoils problem is a bit of a game issue. It's being looked at. First you need to close your landing gear (CTRL-L) which takes a second, then close your sFoils (V) and then you are ready to go ;) I believe Angle wants to add some mission text into it so that it's more clear. Again this is really only an issue in the training missions due to you being able to respawn. When you leave a hangar normally you will be ready to fight.
Murphy was an optimist! I am a pessimist!
And always remember that a smile is cheaper than a bullet! (District 9)
Webmaster of the X-Wing Alliance Upgrade Project

User avatar
Ace Antilles
Admiral (Moderator)
Posts: 6124
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Thu Jul 08, 2021 8:18 am

brakogar wrote:
Thu Jul 08, 2021 4:46 am
Issue: No Speech - All other sound effects work fine. No other issues aside from voice speech not present neither in briefings or in flight.

Hi Team,

Thank you or such a great conversion! I am looking forward to fully experiencing it. I was able to successfully install it and ran the Palpatine total conversion from the menu as instructed in the install video but I have run into the following issue (assuming it is one) in both reimagined and classic versions:

During the briefing and in-flight there is no voice speech at all. Music and sound effects appear to be fine. I have tried re-installing from scratch but issue repeats itself. Please advise. Thank you again.
If you're using a CD XWA version. Make sure you copy all the Wave folders from both CDs to the pc itself
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

User avatar
Ace Antilles
Admiral (Moderator)
Posts: 6124
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Thu Jul 08, 2021 8:21 am

Gringlas wrote:
Thu Jul 08, 2021 5:57 am
Just played for an hour through the training mission and the first mission of the tour of duty. Very nice work so far.
I've got two issues, which maybe are not bugs realy, but didn't wanted to start a new topic for those.

1) Is there no Tech Room available?
2) Don't know if its XWAU or TFTC, but the missile lock sound is annoying as hell. In my mind it sounded very different in Tie Fighter way back.
3) In training mission 4 (Gunboat) I got destroyed. I like that the mission doesn't fail instantly and you get redeployed in a new craft.(Is this a feature in all mission, or only in training?) But it had s-foils closed and landing gears down. Shouldn't it be battle ready?
I just read through this topic and thanks @Ace Antilles I now know the key mapping for landing gears, but which is the key for s-foils (wasn't even able to find it in the original handbook - maybe I'm blind though ^^).
The sounds have been added by TFTC. The original ones are in the backup folder
I've messed about with Imperial sounds a little and may release some in the future

You change ships because of the MP hook.
Landing gear was added by XWAU years ago ;)
I think TFTC are going to have to disable it on some ships personally
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

brakogar
Recruit
Posts: 9
Joined: Thu Jul 08, 2021 4:39 am

Post by brakogar » Thu Jul 08, 2021 6:17 pm

Ace Antilles wrote:
Thu Jul 08, 2021 8:18 am
brakogar wrote:
Thu Jul 08, 2021 4:46 am
Issue: No Speech - All other sound effects work fine. No other issues aside from voice speech not present neither in briefings or in flight.

Hi Team,

Thank you or such a great conversion! I am looking forward to fully experiencing it. I was able to successfully install it and ran the Palpatine total conversion from the menu as instructed in the install video but I have run into the following issue (assuming it is one) in both reimagined and classic versions:

During the briefing and in-flight there is no voice speech at all. Music and sound effects appear to be fine. I have tried re-installing from scratch but issue repeats itself. Please advise. Thank you again.
If you're using a CD XWA version. Make sure you copy all the Wave folders from both CDs to the pc itself
Hi Thank you for replying. I am using the Steam version of X-Wing Alliance and referring to Tie Fighter Total Conversion briefings.

User avatar
Ace Antilles
Admiral (Moderator)
Posts: 6124
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Thu Jul 08, 2021 6:58 pm

brakogar wrote:
Thu Jul 08, 2021 6:17 pm
Ace Antilles wrote:
Thu Jul 08, 2021 8:18 am
brakogar wrote:
Thu Jul 08, 2021 4:46 am
Issue: No Speech - All other sound effects work fine. No other issues aside from voice speech not present neither in briefings or in flight.

Hi Team,

Thank you or such a great conversion! I am looking forward to fully experiencing it. I was able to successfully install it and ran the Palpatine total conversion from the menu as instructed in the install video but I have run into the following issue (assuming it is one) in both reimagined and classic versions:

During the briefing and in-flight there is no voice speech at all. Music and sound effects appear to be fine. I have tried re-installing from scratch but issue repeats itself. Please advise. Thank you again.
If you're using a CD XWA version. Make sure you copy all the Wave folders from both CDs to the pc itself
Hi Thank you for replying. I am using the Steam version of X-Wing Alliance and referring to Tie Fighter Total Conversion briefings.
@AngeI is this a known issue you have a fix for?
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

Post Reply