Gimbal lock fix?

Want to edit the game, build your own craft and missions? Here you'll find help, tools, guides and people to discuss with.

Re: Gimbal lock fix?

Bman
Lieutenant Commander
Posts: 1124
Joined: Mon Apr 05, 2004 11:01 pm

Post by Bman » Sat Dec 31, 2022 11:27 pm

keiranhalcyon7 wrote:
Sat Dec 31, 2022 8:44 am
blue_max wrote:
Sat Dec 31, 2022 6:59 am
Apparently, classic TFTC doesn't have that feature, so it can be turned off for the Gimbal Lock fix now.
Understandable, since that feature didn't exist until at least XvT... but I wonder, how did TFTC disable it???
I believe Random helped Angel make that patch for TFTC in a post I saw. He would have more details on how that works if interested.
W-I-P: ISD-II, (Imp) Escort Carrier, NL-1 Platform, Misc, & TFTC.

User avatar
blue_max
XWAU Member
Posts: 2253
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Mon Jan 02, 2023 4:46 am

I know there's still a few bugs, but I think this is stable now. So I published a new update in the official Downloads section. You guys can get it there now.

Also: please download the latest Joystick Hook. You'll need it for the gimbal lock fix.

batuta
Cadet 1st Class
Posts: 115
Joined: Tue Oct 13, 2020 1:34 pm

Post by batuta » Mon Jan 02, 2023 12:19 pm

Great thank you very much.

korekwerner
Cadet 1st Class
Posts: 154
Joined: Wed Mar 20, 2019 7:04 pm

Post by korekwerner » Tue Jan 03, 2023 12:59 am

Thank you blue_max for the changes made. I did some more tests and these are my observations.
The departure of ships from the hangar is still somewhat random, but it depends on the ship :).
The YT1300 also behaves strangely when docking to platforms and picking up objects. During these automatic maneuvers, you can change the position of the ship in cockpit mode, but switching to the external camera view resets the view and makes changes.
I think you know about these problems, and if not, I can help with further tests. Thank you for what you do.

test video - https://youtu.be/tdizVQMeNHs

User avatar
blue_max
XWAU Member
Posts: 2253
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Tue Jan 03, 2023 6:11 pm

korekwerner wrote:
Tue Jan 03, 2023 12:59 am
The departure of ships from the hangar is still somewhat random, but it depends on the ship :).
Which ships? The departure from the hangar only seems to be messed up for me if the joystick isn't centered, and then again, I can only reproduce it if I restart the mission at least twice. In what missions are you seeing this behavior?
The YT1300 also behaves strangely when docking to platforms and picking up objects.
Oops, I didn't even remember the docking operation. I'll fix it.
I think you know about these problems, and if not, I can help with further tests. Thank you for what you do.
I didn't know about the docking operation, so thanks for reporting that!

User avatar
blue_max
XWAU Member
Posts: 2253
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Wed Jan 04, 2023 5:44 pm

BTW, there's a new drop of the effects beta. I fixed the docking problems, and I added a new setting to manually disable the rudder in GimbalLockFix.cfg for those who need it.

The gimbal lock fix is now disabled by default since that caught many people off-guard, but it can be enabled in GimbalLockFix.cfg.

batuta
Cadet 1st Class
Posts: 115
Joined: Tue Oct 13, 2020 1:34 pm

Post by batuta » Wed Jan 04, 2023 5:47 pm

Great thank you very much

korekwerner
Cadet 1st Class
Posts: 154
Joined: Wed Mar 20, 2019 7:04 pm

Post by korekwerner » Sat Jan 07, 2023 3:05 pm

Further tests with the latest version of gimbalfix - 03.01.2023
Observations:
- departure from the hangar and positioning of the ship depends on the calibration of the joystick / gamepad.
actually restarting the mission fixes this bug, but I think it is due to the deadzone setting.
I did tests on XWAU 5.5 and the behavior is the same.
When I have a gamepad connected - the problem occurs, when I disconnect the gamepad there is no problem.

A new bug that I noticed is the ability to control the ship when it takes over the AI (2nd family mission).
Interestingly, switching to the turret causes the AI to take control of the ship and continue the mission according to the scenario. Overall, it looks cool and is extremely helpful because you can correct the deficiencies of AI piloting. However, this is not correct game behavior.
tests in progress....
Thank you.

video link - https://youtu.be/RuzS0t9kp_o

User avatar
guru_redeye
Cadet 2nd Class
Posts: 61
Joined: Wed Oct 06, 2004 11:01 pm

Post by guru_redeye » Sun Jan 08, 2023 10:38 pm

I have only tested the fix with Z95 yet and it indeed removes the gimball lock but it disables the standard XWA 'Roll' function - the one you can control with x-axis of the js and activate by a js button bound to it (it's also bound to Alt-3 keycomb by default and it's named "Roll/Target ship in sights"). Altering "enable_rudder = ..." setting does not help. If I set enable_gimbal_lock_fix to 0 again I get back the Roll function.

User avatar
blue_max
XWAU Member
Posts: 2253
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Tue Jan 10, 2023 1:11 am

Thanks for reporting these problems. I'll check what's going on.

korekwerner
Cadet 1st Class
Posts: 154
Joined: Wed Mar 20, 2019 7:04 pm

Post by korekwerner » Tue Jan 24, 2023 4:58 pm

Gimballlock is almost fixed and maybe just maybe another small glitch could be fixed as well - small horizontal backdrop jumps.
I already aske @blue_max about it and I see light at the end of the tunnel.
video with this backdrop glitch - https://youtu.be/50X4mUftk1U
Thank you.

User avatar
AngeI
Ensign
Posts: 499
Joined: Sun Jan 24, 2016 5:27 pm

Post by AngeI » Thu Jan 26, 2023 12:05 pm

Isn't the background jumping/jittering about a long standing issue with the engine though?

korekwerner
Cadet 1st Class
Posts: 154
Joined: Wed Mar 20, 2019 7:04 pm

Post by korekwerner » Thu Jan 26, 2023 10:52 pm

AngeI wrote:
Thu Jan 26, 2023 12:05 pm
Isn't the background jumping/jittering about a long standing issue with the engine though?
You are right, but my question and request comes down to whether there is a possibility to fix this old bug. Blue_max has shown that he can do the impossible.
The longer I watch what JeremyaFr and Blue_max do, I come to the conclusion that XWA is the best space engine for Star Wars fans. With minor imperfections, but giving a lot of possibilities.

User avatar
AngeI
Ensign
Posts: 499
Joined: Sun Jan 24, 2016 5:27 pm

Post by AngeI » Fri Jan 27, 2023 11:54 am

korekwerner wrote:
Thu Jan 26, 2023 10:52 pm
You are right, but my question and request comes down to whether there is a possibility to fix this old bug. Blue_max has shown that he can do the impossible.
The longer I watch what JeremyaFr and Blue_max do, I come to the conclusion that XWA is the best space engine for Star Wars fans. With minor imperfections, but giving a lot of possibilities.
I did ask him about this a long time ago, this was the response:

blue_max — 01/23/2022 9:52 PM
I'm not sure what's the deal with the backgrounds, but we can try replacing them with Environment Maps
The backgrounds are currently rendered as big cubes, but I don't know, maybe that cube is transformed using fixed-point logic (i.e. less precision)
If we remove them altogether and replace them with Environment Maps... maybe

korekwerner
Cadet 1st Class
Posts: 154
Joined: Wed Mar 20, 2019 7:04 pm

Post by korekwerner » Fri Jan 27, 2023 8:35 pm

As I see blue_max has learned a lot during this year and his skills are at a very high level in terms of the XWA engine. If he manages to change the way background works, it will be the next big step in modding XWA. Fingers crossed.
Together with JeremyaFr, they form a complementary team.
Gimbal Lock Fix shared today by JeremyaFr works perfectly on my computer.
Thank you.

Post Reply