New player - is there online/Lan co-op of the main campaign?

In here you can discuss what is going on in the project, offer help, praise or critique!
Post Reply

New player - is there online/Lan co-op of the main campaign?

RightRudderLeftStick
Recruit
Posts: 1
Joined: Wed Feb 14, 2024 1:34 pm

Post by RightRudderLeftStick » Wed Feb 14, 2024 1:42 pm

Last time I played XWA was a quarter century ago!

Learning about XWAU got me interested in getting back into it. My friends play a lot of Co-op IL2 in VR, and would be interested in trying XWA if we could play the campaign (at least the rebel alliance part)

Or are there community made rebel alliance campaigns we could fly?

Timbo8504
Cadet 4th Class
Posts: 11
Joined: Sun Aug 20, 2023 11:59 pm

Post by Timbo8504 » Wed Feb 14, 2024 4:11 pm

Not Rebel Alliance based, but over in the Emperor’s Hammer we have more than 700 custom XWA missions to play.

https://www.emperorshammer.org/about.php

As to co-op there is a multi-player hook that is sorta functional, but is still in beta. I know there is at least one member on here activity working to get it functional.

User avatar
the_stag
Rebel Alliance
Posts: 134
Joined: Sun Jun 14, 2020 3:47 pm

Post by the_stag » Sat Feb 17, 2024 5:34 pm

I've played a couple of campaign multiplayer missions with my son. The problem is that while the campaign multiplayer hook is (mostly) functional, the only missions that work out of the box are where you're flying the YT-2000 or Millennium Falcon because there's 2 seats on those craft. I did edit some other missions to add player flyable craft with varying degrees of success. I think there's an issue with the hangar that causes problems. I hope to convert all the campaign missions for 8 player co-op, but I need to spend more time to diagnose why missions won't launch/sync most the time.

If anyone else is working on adapting missions for that purpose please let me know. We can pool our resources, or I can stop spending my time re-creating the wheel.

Bman
Lieutenant Commander
Posts: 1170
Joined: Mon Apr 05, 2004 11:01 pm

Post by Bman » Mon Feb 19, 2024 12:55 am

Stag, thanks for posting that. Curious ... so is the hosting player (you) flying in the cockpit (say YT-2000) and when your son joins your game, does he pick the same FG craft and is automatically put in one of the Gunner turret wells (G key), or how does that process work? Never used the MP feature. When TFTC is basically done, it will probably expand into this coop frontier.
W-I-P: TFTC, MC Viscount Cr., ISD-II Avenger, NL-1 Platform, Ton-Falk Esc. Cr., & Misc.

User avatar
the_stag
Rebel Alliance
Posts: 134
Joined: Sun Jun 14, 2020 3:47 pm

Post by the_stag » Sun Mar 03, 2024 2:54 am

@Bman Sorry for the late response, I was out of town and then wanted to do some more testing before I responded.

Apparently I was misremembering playing the family missions in the same craft. I've been unable to recreate that, despite my best efforts. It appears to work, but once you launch the mission it takes a few extra seconds for the non-host to get to the briefing, and then they never launch into the mission and the connection times out on the hosts end. I've also had issues when the gun controls being jumpy and virtually not usable. This is not the case when in separate craft.

However, I have been successful in playing the campaign in multiplayer mode after modifying the missions. This includes the family missions as long as players are in different ships. There are some syncing issues, but it's playable. @JeremyaFr, you might be interested in these findings. I'm happy to do more testing or provide more info if you have any questions.

User avatar
the_stag
Rebel Alliance
Posts: 134
Joined: Sun Jun 14, 2020 3:47 pm

Post by the_stag » Sat Mar 16, 2024 11:56 pm

I want to take some space here to document my experience and findings with multiplayer. Make a note that all the errors I describe below happen when the tour multiplayer hook is enabled or disabled, whether or not I'm playing the campaign or skirmishes.

I've had success getting campaign missions working with the hook enabled. I've modified the missions so that there are multiple players and that messages go to all players and have triggers that are defined when all players have arrived in a region. For the most part they work without further enhancement.

Now let me define "work": everything starts out well enough, but the games begin to de-sync shortly thereafter. I've been experiencing de-sync issues where all players continue to play, but craft end up in different places. Times get out of sorts and eventually nothing matches anymore. If I kill a craft, that craft is still alive and somewhere completely different for the other players. It seems to depend on the complexity and/or the number of craft in a mission (Hyperspace also seems to cause issues, but sometimes it doesn't). For example, battle 1, mission 2: Reconnaissance of Imperial Task Force: This is a fairly straightforward mission with few ships and few fighters. This is the only mission I've been able to play start to finish in multiplayer without de-syncs, and I haven't been able to do it consistently. Compare that to Rescue Echo Base Prisoners. Each region has several craft, and many different things going on at the same time. I can't get out of region 2 (where all the neutral/civilian craft are) without everything falling apart.

The setup I'm using is 3 custom made PC's with mid-range video cards (they don't match, but I can play with full framerate) and 32GB of RAM each. They are all connected via WiFi to an access point that reports an excellent connection. I've tried using all the TCP/IP connection settings with similar results (Internet yes and no and all the different update rates). The lower the update rate, the slower and worse the experience is for the other players. I also applied the IPXWrapper from solemnwarning.net. The first game I played with IPXWrapper was the successful "Reconnaissance of Imperial Task Force", but that experience hasn't been repeatable. I want to think that the game plays better when using IPXWrapper, but that's mostly conjecture.

Lastly, when I play XWA vanilla or XvT I don't have those issues. Once in a while there might be a hiccup in the game, but there are no de-syncs and everything matches after the screen jumps around a bit. I'm hoping to do some more testing in the next few weeks with attempts to play over a wired connection as well as test with other versions of XWAU. Please let me know if anyone has any questions. I'd be glad to whatever I can to help get multiplayer working again.

CrisGer
Cadet 2nd Class
Posts: 71
Joined: Fri Oct 17, 2008 10:23 pm
Contact:

Post by CrisGer » Sun Mar 31, 2024 4:24 pm

I didnt know the Emperors Hammer was still around, I remembered it from before but have been away for some time and will check it out. thanks for posting and giving the link

much appreciated.
Director and Lead Admin
3D World and Game Developers Group LInkedin
"We Build Worlds"

Post Reply