XWAU 2020 Mega Patch Update 6: Bug Fix

All the XWAU recent release news from the project can be found here
Post Reply

XWAU 2020 Mega Patch Update 6: Bug Fix

User avatar
Ace Antilles
Admiral (Moderator)
Posts: 7804
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Thu Dec 21, 2023 10:19 pm

Image


XWAU 2020 Mega Patch Update 6: Bug Fix – December 20th, 2023
Small fixes to the Update 6 with Star Destroyers, Hooks and Ddraw.


XWAU ONLY! NOT FOR TFTC

There have been a few bugs found in Update 6. Mostly minor ones but enough to make a small bug fix release to tide things over until the next full release.

You can download this now from the Download page.
Look for XWAU 2020 AddOn Pack Version 6.0.1


Bug Fixes

Special Effects - Ddraw: Version 2.4.22 by Blue Max and m0rgg.
Fix memory leaks and crashes related to tangent buffers in the hangar.
Normal mapping is now computed using the cotangent frame in the GPU during the forward rendering pass.
Re-enable mouse emulation.
GimbalLockFix.cfg deleted from installation.

Babu Friks Configurator: Mouse options are now available again under Joystick Emulation.

Imperial Star Destroyer: Hangar blast door fixes. Floor launch now the default.

Imperial, SSD and Victory Star Destroyers: Hangar model, Material and Hangar map layout fixes.

Victory Star Destroyer 2: Engine ini settings have been fixed to show properly.

Hooks - The latest Hooks and CFG files by JérémyaFr as of the date of this release.
Jeremy has fixed a number of Hook issues, relating to Skirmish mode and backdrops and more.
Hooks are being updated as issues or improvements are found but these are the latest stable files we have included.
For more details or to report any issues that might relate to Hooks please visit the XWAU Forum.
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

User avatar
Ace Antilles
Admiral (Moderator)
Posts: 7804
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Thu Dec 21, 2023 10:20 pm

And I will leave you with a little teaser of things we are working on and coming out next year.

A very Merry Christmas from all of us at the XWA Upgrade!

Slave1.jpg
You do not have the required permissions to view the files attached to this post.
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

Bailknight
Recruit
Posts: 9
Joined: Sun May 05, 2019 2:50 pm

Post by Bailknight » Thu Dec 28, 2023 2:56 pm

Thanks for bring great patch as always. However sadly I have serious performance issue after install 6.0.1 . I mostly tested B7M2 (The Battle of Endor) and in 6.0.0 Performance in game was mostly stable at 40fps with RT hard shadow but after 6.0.1 same scene dropped to 15fps. Even completely remove special effect and roll back to ddraw didn't improve fps. I did complete reinstall to confirm 6.0.0 was fine and right after install 6.0.1 performance issue reappear. Also after 6.0.1 patch ISD(don't know which one but I guess ISD2) have strange green and purple billboard on it's hull. Tested PC on Windows 11 Ryzen 7840U CPU with Radeon 780M iGPU (GPD Win Mini).

User avatar
Vince T
Fleet Admiral (Administrator)
Posts: 14035
Joined: Fri Apr 27, 2001 11:01 pm
Contact:

Post by Vince T » Thu Dec 28, 2023 4:35 pm

It appears there has been a mix-up of ini files in update 6. I didn't notice it as I was already using my new versions

For a quick fix please follow these instructions:

1) Go into your Game directory and then into the \Flightmodels\ folder
2) Locate the file ImperialStarDestroyer2.ini and open it with any text editor, such as NotePad or NotePad++.
3) Locate the section "[ObjectProfiles]" and look for the Default-entry. If the nubmer behind it is 24, change it to 24,
3b) If there is no [ObjectProfiles] section, add it with following lines

Code: Select all

[ObjectProfiles]
Default = 24
FPSFriendly = 2, 3, 5, 24, 46
ErrantVenture = 21, 22, 27, 29, 31, 33, 35, 37, 39, 41, 43, 45
Your ship, Captain. I need a drink. - Vince Trageton
Vince T's X-Wing HQ - where the bad guys get their gear

User avatar
Ace Antilles
Admiral (Moderator)
Posts: 7804
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Thu Dec 28, 2023 9:44 pm

Sorry for the error.
The whole Bug Fix will be updated soon.
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

Bailknight
Recruit
Posts: 9
Joined: Sun May 05, 2019 2:50 pm

Post by Bailknight » Fri Dec 29, 2023 1:57 am

I think I found culprit hook that cause my FPS drop. I did some test with old hooks in backup folder by replacing 6.0.0 hooks with 6.0.1 hooks one by one and when I replace "Hook_Mission_Tie.dll" from 6.0.1 framerate suddenly cut halved. Framerate return back to usual 40fps when I replace it to 6.0.0 again. Other hooks that updated in 6.0.1 not cause any framerate drop issue.

User avatar
Vince T
Fleet Admiral (Administrator)
Posts: 14035
Joined: Fri Apr 27, 2001 11:01 pm
Contact:

Post by Vince T » Fri Dec 29, 2023 9:00 am

Good find. Maybe @JeremyaFr can take a look.
Your ship, Captain. I need a drink. - Vince Trageton
Vince T's X-Wing HQ - where the bad guys get their gear

User avatar
Ace Antilles
Admiral (Moderator)
Posts: 7804
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Fri Dec 29, 2023 11:08 am

Greetings all.
There was a slight issue with a file in the current bug fix, ironically.
In particular the Imperial Star Destroyer 2.

A new version has now been updated to the downloads page, which if you install it then it will correct the problem.
Sorry for any inconvenience.
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

User avatar
JeremyaFr
XWAU Member
Posts: 3888
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Fri Dec 29, 2023 12:19 pm

Bailknight wrote:
Fri Dec 29, 2023 1:57 am
I think I found culprit hook that cause my FPS drop. I did some test with old hooks in backup folder by replacing 6.0.0 hooks with 6.0.1 hooks one by one and when I replace "Hook_Mission_Tie.dll" from 6.0.1 framerate suddenly cut halved. Framerate return back to usual 40fps when I replace it to 6.0.0 again. Other hooks that updated in 6.0.1 not cause any framerate drop issue.
Hello,
Thank you for the bug report.
The issue was related to a new feature (skirmish ini settings) added in the mission tie hook. There was a missing line in the engine sound hook. The result was that the ini setting was reloaded everytime a sound hook was called.
I've updated the engine sound hook. The issue should be fixed.

User avatar
Ace Antilles
Admiral (Moderator)
Posts: 7804
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Sat Jan 27, 2024 9:45 pm

Many thanks to @LPhoenix who has created a fix for a bugged mission.
[B6M2] BATTLE 6 - MISSION 2 - LOCATE MERCENARY BASE

In this mission for some reason the IRD fighters flew a long way out and back.
To download the mission and to see what has been changed see this thread.

https://forums.xwaupgrade.com/viewtopic.php?t=14288
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

Post Reply